Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Rampage 2x200 watt amp

JONNO13

New Member
Joined
Mar 26, 2009
Messages
2
Reaction score
0
Points
0
Members Ride
VS Equipe SII STOCK!!!
hi i went out and bought a rampage 2x200 watt amp hooked it up to the headunit all properly even got my mate who is a car stereo installer to check it i did it properly and then i brifged my sub off the amp.

now the problem is. it goes like **** lol my mates sony xplod 200 watt amp pumps twice as hard as mine, could it be something wrong inside the amp itself?
 

Fun_Bucket

New Member
Joined
Mar 23, 2009
Messages
2,990
Reaction score
5
Points
0
Age
35
Location
Cairns White Rock
Members Ride
Cruze II sri
I don't think the amp itself would be faulty, if your mate is a stereo installer like you said, he would have picked up on whether or not your amp was faulty, i think the problem is you get what you pay for, rampage from what i know is a very cheap brand sold through repco...A sony Amp, or any other repirable brand, of the equivelnt output is always going to perform better than a cheaper unit such as the rampage you purchased. Also when bridging an amplifier, you have to know what OHM rating it is stable at, whether it be 4ohm, 2ohm, ect, ...
 

JONNO13

New Member
Joined
Mar 26, 2009
Messages
2
Reaction score
0
Points
0
Members Ride
VS Equipe SII STOCK!!!
ok thanx man, btw i didnt ask him to check the amp he just checked if i connected the head unit wires properly. maybe its cause i bought it second hand lol
 

Fun_Bucket

New Member
Joined
Mar 23, 2009
Messages
2,990
Reaction score
5
Points
0
Age
35
Location
Cairns White Rock
Members Ride
Cruze II sri
Then there's the possibililty of a fault, sorry i thought you got it new....
 

holdenboy

Custom Car Stereo Systems
Joined
Aug 31, 2008
Messages
2,330
Reaction score
15
Points
0
Age
39
Location
Nelson Bay NSW
Members Ride
VR Wagon
Also might be worth checking the filter settings (HPF/LPF). For a sub you wanna set it on LPF and the frequency should be around 80-100hz if it adjustable. Also check the gain control, it should be around the 1/2-3/4 mark.
 
Top