Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Speedo trip meter no lights on

NeddyBear

Veteran Mountain Biker
Joined
May 5, 2011
Messages
1,488
Reaction score
196
Points
63
Location
Rubyvale, Qld
Members Ride
2004 2.5L Subaru Outback
Noticed the other night that the speedo kilometer section no longer lights up.
Anyone else ever had this and fixed theirs, maybe a fuse.
Everything else seems to be working correctly, lights, blinkers, stoplights, remainder of the dash lights all good.
 

krusing

Well-Known Member
Joined
Jun 21, 2014
Messages
2,958
Reaction score
1,463
Points
113
Location
Melbourne Bayside 3193
Members Ride
2002 VY L67 Calais Sedan, 2012 VE L77 Calais Wagon
Could be a fuse, or dimmer switch, where it could also take out some of the illumination of other control buttons, like window button, and radio illumination etc.
 

NeddyBear

Veteran Mountain Biker
Joined
May 5, 2011
Messages
1,488
Reaction score
196
Points
63
Location
Rubyvale, Qld
Members Ride
2004 2.5L Subaru Outback
How'd you guys fix yours? which globe or fuse.
 

accentstencil

Well-Known Member
Joined
Jun 30, 2005
Messages
8,266
Reaction score
461
Points
83
Age
69
Location
Eschol Park, Sydney
Members Ride
WH II Caprice, 5.7 2018 Equinox LTZ V
How'd you guys fix yours? which globe or fuse.
There is no separate fuse just for that, so it's a matter of pulling out the cluster and replacing the globe with a very expensive one from Holden (if still available) or an LED. It will be the bottom globe in the middle.
 
Top