Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

transmission trouble

motormouth

New Member
Joined
Jan 15, 2013
Messages
19
Reaction score
0
Points
1
Location
Bonnet Bay NSW
Members Ride
Vs ute v6 Auto
Hi All, I have a small problem with my 95 vs ute transmission , When I go in reverse then to drive it seems to take a few seconds, more so when it's cold.It also has a slight shudder in first and second gear.
Do you think that a service might fix it or does it have the symptoms of something more serious.
Your thoughts would be appreciated.
 

Brett_jjj

Well-Known Member
Joined
Oct 16, 2009
Messages
6,805
Reaction score
96
Points
48
Location
Tamworth NSW
Members Ride
vs commodore
It may just need a good service, a new filter and fluid and the pan magnet cleaned.. Its easy to do this job yourself if you have car stands or ramps.. $25 for a new filter kit, (which includes a new pan gasket etc), and another $30 or so for 5 litres of dexron 111 (3) trans fluid. A lot cheaper than paying for a mechanic to do it, and it doesnt have to be a very messy job if its done right..
 

Jxfwsf

Well-Known Member
Joined
Feb 20, 2011
Messages
4,852
Reaction score
97
Points
48
Location
Aus
Members Ride
commodore
full service and flush and throw in a bottle of transmission treatment (i've had good results from the nulon stuff). see how that goes.


If that doesn't fix it then it sounds like it's on it's way out unfortunately.
 
Top