Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

unstable engine

daddybird

New Member
Joined
Mar 29, 2011
Messages
3
Reaction score
0
Points
0
Location
brunei darussalam
Members Ride
holden commodore vl 2.0
I have a commodore vl 2.0 with Nissan Engine which was recently just doing fine. After last week the idle was not stable and if it it is on the lowest idle the engine runs so rough having black smoke seems like choked from the inside. when i check out the spark plugs it has black carbon on it.. i decided to change to new spark plugs then it runs smoothly again on it normal idle after a week later again the problem starts again. i tried changing the ignition coil it helped a bit but still there is the rough engine running then after a while the engine would stop.

Do anyone of you guys have the same experience maybe u have some ideas on how to solve this problem.

Thanks
Kim
 

nasty1

New Member
Joined
Feb 16, 2008
Messages
1,739
Reaction score
3
Points
0
Location
adelaide
Members Ride
vy2 clubsport
Have you messed with the timing? Sounds very rich to me
 

daddybird

New Member
Joined
Mar 29, 2011
Messages
3
Reaction score
0
Points
0
Location
brunei darussalam
Members Ride
holden commodore vl 2.0
im not quite sure if i've messed with the timing.. but if in that case how would i fix this thing
 

nasty1

New Member
Joined
Feb 16, 2008
Messages
1,739
Reaction score
3
Points
0
Location
adelaide
Members Ride
vy2 clubsport
have you moved or adjusted the dizzy?
 

nasty1

New Member
Joined
Feb 16, 2008
Messages
1,739
Reaction score
3
Points
0
Location
adelaide
Members Ride
vy2 clubsport
The dizzy has all the leads plugged into it
 
Top