Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

--urgent-- dash not lighting up

ben k

ben
Joined
Aug 14, 2005
Messages
117
Reaction score
0
Points
0
Age
32
Location
radelaide...bay area
Members Ride
VP Calais S2
got a 100km trip to do tonite through the country...have a problem though

my dash (speedo/taco/trip computer) aren't lighting up when my headlights are on....when i have my headlights off my trip computer lights up and as i switch it to parkers everything lights up for a sec but thats it

is this a globe or electrical problem?

bit dangerous/annoying when everything is pitch black and you don't really know what speed you're doing on the victor road which im doing tonite....thank god for cruise control

any help appreciated

cheers

ben
 

azkwazere

Ahhh Yes, Ahhh Yes....
Joined
May 30, 2005
Messages
1,813
Reaction score
38
Points
0
Age
33
Location
.....SE Burbs
Members Ride
VP 5-SPD / 24-SPD Racer Hybrid
The only thing that i could suggest is that maybe the connector for your dimmer light is loose. Behind your clster surround (oval thing with buttons each side) there is a couple of light plugs/looms check to see if the loom plugged into the dimmer switch is secure. THe reason i suggest this is that that switch is a pass through to your cluster, if its not in, non of the daash lights will work (yes its happened to me....) Other than that im stumped!

aZk.
 

NORTI

Crazy VS lady
Joined
May 22, 2004
Messages
2,427
Reaction score
149
Points
63
Location
Adelaide
Members Ride
VS Senator, VS SS, VS Ute, VP BT1
also check other fuses.... sometimes a blown fuse elsewhere will give a dash light fault, cant remember which one it was....



D.
 

Kid_Random

New Member
Joined
Sep 9, 2006
Messages
15
Reaction score
0
Points
0
Members Ride
VN Berlina
i had the same problem mate...
Fuse was the answer
need a 5amp
 
Top