Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VR pully nuts loosing when engine runing

sekiflying

New Member
Joined
Mar 8, 2012
Messages
45
Reaction score
0
Points
0
Location
Runcorn, Brisbane
Members Ride
VR
I found out the the 4 nuts on the pully become loosing when I the engine running.
I am pretty sure I tight it up normally.

I think I bend a bit of the seal which in front of the pump(Because I had trouble to put it into pump)
Is the loosing because of the front seal? will I fix it if I replace a new pump?
 

IBLOWN

Well-Known Member
Joined
Sep 13, 2005
Messages
2,123
Reaction score
41
Points
48
Age
42
Location
Sydney
Members Ride
VS V6 TT/'13 VF Senator/'11 WM CapriceV/Hayabusa
If your nuts are loosing you must not have tight up properly. They cant come loosing.

If you bend a bit of the seal then pump will leak. Better change seal so not leak.

Nuts loosing wouldnt be from bend seal. Although if whole pump on angle then maybe nuts loosing.
 
Last edited:

Not_An_Abba_Fan

Exhaust Guru
Joined
Aug 18, 2006
Messages
14,638
Reaction score
1,324
Points
113
Location
Bunbury, WA
Members Ride
Strange Rover
:rofl2: What he ^^^ said.
 

immortality

Can't live without smoky bacon!
Staff member
Joined
Apr 15, 2006
Messages
18,127
Reaction score
7,417
Points
113
Location
Sth Auck, NZ
Members Ride
HSV VS Senator, VX s2 Calais S/C
Couldn't have said it better ^^^^^ :rofl:

No learnd nough :hmmm:
 
Top