Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

vr ss heats up fast then cuts out runs real hot

U mad bro?

New Member
Joined
May 31, 2013
Messages
24
Reaction score
0
Points
0
Age
32
Location
Australia
Members Ride
vr ss
hey

the vr ss I got heats up fast then cuts out.

No oil leaks or any thing has 5.7 lt injector small cam but would that make it run hot?
Like over half way tempo wants to stall don't know what the problem is.
Book Into merchanic but That said that cant find what it wrong

Checked for blocks found nothing
twin thermo's fans they don't keep it cool
does't have a crack head or anything

does need a tune would that maybe fix it?

cheers

p.s The guy who i got it off said it had a different thermo stat and the twin fans that why the engine light is all way on
 
Last edited:

BlackVXGTS

Well-Known Member
Joined
Aug 14, 2004
Messages
4,413
Reaction score
1,131
Points
113
Location
Melbourne, SE
Members Ride
GEN-F2 GTS A6, VS Clubsport 185 A4
First step would be to display your error codes to see why the engine light is "all way" (sic) on. Use the link below. Assuming the fans are starting and running OK:

1. Make sure the thermos have a shroud and that the shroud is sealed properly to the radiator.
2. Check the thermostat to make sure it isn't blocked or faulty. I'd be installing a standard thermostat.
3. Replace the water pump.
4. Change your mechanic.
5. Consider using spell check. :)

https://forums.justcommodores.com.au/threads/checking-error-codes-vr-vs-revised.22307
 

U mad bro?

New Member
Joined
May 31, 2013
Messages
24
Reaction score
0
Points
0
Age
32
Location
Australia
Members Ride
vr ss
First step would be to display your error codes to see why the engine light is "all way" (sic) on. Use the link below. Assuming the fans are starting and running OK:

1. Make sure the thermos have a shroud and that the shroud is sealed properly to the radiator.
2. Check the thermostat to make sure it isn't blocked or faulty. I'd be installing a standard thermostat.
3. Replace the water pump.
4. Change your mechanic.
5. Consider using spell check. :)

https://forums.justcommodores.com.au/threads/checking-error-codes-vr-vs-revised.22307
thanks for the info will replace all that stuff.
Spelling was bad as I was in a rush to get the car !!!!!!!!!!!!!!!!!!!!!!!!!!11
 
Top