Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VS V8 T5, Clutch Issues

Salan95VS

Member
Joined
Jan 20, 2019
Messages
46
Reaction score
2
Points
8
Age
24
Location
Wagga, NSW, Australia
Members Ride
95 VS V8 Ute
Am having major issues getting my new clutch industries HD clutch to engage, have set the pivot at correct spec (105mm), have tried other settings too & makes no difference, it was engaging without a tail shaft & now that it does it won’t get any gears, only grinds & is making a weird noise from the bell housing. Have no idea what to do so can anyone please help?
 

vs-lover

Well-Known Member
Joined
Mar 9, 2013
Messages
2,443
Reaction score
1,590
Points
113
Location
Adelaide
Members Ride
VS S2 Calais, VS S2 Exec Wagon, VS S2 Acclaim
Just wondering if you've got the clutch plate the correct way around ?
 

Salan95VS

Member
Joined
Jan 20, 2019
Messages
46
Reaction score
2
Points
8
Age
24
Location
Wagga, NSW, Australia
Members Ride
95 VS V8 Ute
As far as I know it is the right way around, I will be pulling it all apart tomorrow so I’ll double check that as well. Is there anything else that could make this all happen?
 

Salan95VS

Member
Joined
Jan 20, 2019
Messages
46
Reaction score
2
Points
8
Age
24
Location
Wagga, NSW, Australia
Members Ride
95 VS V8 Ute
The clutch plate is not in backwards & everything about the clutch looks fine can’t really fault it unless it’s something internal.
 

_R_J_K_

Well-Known Member
Joined
Dec 20, 2008
Messages
5,937
Reaction score
1,205
Points
113
Members Ride
Zenki S14
Are you able to take the fork boot off and see if the bearing carrier is still captive in the fork?
 

Salan95VS

Member
Joined
Jan 20, 2019
Messages
46
Reaction score
2
Points
8
Age
24
Location
Wagga, NSW, Australia
Members Ride
95 VS V8 Ute
Are you able to take the fork boot off and see if the bearing carrier is still captive in the fork?
Yeah I did that & it was still captive in the fork. I measured it all up today against a mates standard VS V8 clutch kit that’s brand new & the clutch plates are identical in every aspect but the pressure plate in mine is about .065” thicker than his standard one so surely that’s creating a issue right there cause that’s about 1.5mm - 2mm thicker than a standard one , have taken the clutch kit back to repco today & just have to wait & see what Clutch Industries has to say.
 
Top