Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

vz6lt

vz6lt

New Member
Joined
Jul 4, 2013
Messages
6
Reaction score
0
Points
0
Age
39
Location
brisbane
Members Ride
vz calais 6lt
hi guys, anyone got good knowledge of the L76 mines playin up bad it running real rough inst fuel is all over the place rough idle smells badly like petrol too any ideas cheers dan
 

CONROD

Member
Joined
Jul 23, 2012
Messages
550
Reaction score
5
Points
18
Location
SOMEWHERE in the land of OZ
Members Ride
VZ SS THUNDER 6.0l 6 Sp
More info champ if you can, sounds like the O2 sensors could be playing up. Have you recently put extractors (headers) on ?
 

franklinfrog

Member
Joined
Oct 6, 2009
Messages
581
Reaction score
5
Points
18
Location
Brisbane
Website
www.cheapbrisbanebikes.com
Members Ride
VY SS Wagon 5.7 Auto Wikid Postie Bike
More info needed? Rough at idle, acceleration? Fuel smell from engine bay, rear of car? Engine light? Had it scanned for any error codes?

O2 sensors, check air inlet pipes and vacuum hoses properly attached, sealed and not perished, fuel filter blocked? Dirty MAF sensor? Throttle Position Sensor stuffed? Just random ideas.
 

vz6lt

New Member
Joined
Jul 4, 2013
Messages
6
Reaction score
0
Points
0
Age
39
Location
brisbane
Members Ride
vz calais 6lt
hey guys i have had it tuned full exhuaust ss induction gear box re built, i have tryed fuel fillter change oil and oil fillter plugs and leads about 15000km ago, bad fuel smell from exhaust if i put it in park and rev it to 4500 it makes a bad dirty sounding crackle and the revs go upand down by themself
 

vz6lt

New Member
Joined
Jul 4, 2013
Messages
6
Reaction score
0
Points
0
Age
39
Location
brisbane
Members Ride
vz calais 6lt
i put headers and extractors on a while ago and it was fine then
 

franklinfrog

Member
Joined
Oct 6, 2009
Messages
581
Reaction score
5
Points
18
Location
Brisbane
Website
www.cheapbrisbanebikes.com
Members Ride
VY SS Wagon 5.7 Auto Wikid Postie Bike
Revs going up and down by themselves could be a vacuum leak. So check all your little vacuum lines for any cracks or perished rubber.

Give your throttle body a good clean, you want it to be shiny silver clean on the inside. See if this helps, it can make a big difference to have a clean throttle body.

O2 sensors could also be stuffed, if they are it could be running rich and this is the fuel smell you're getting. You can remove them and give them a clean, but usually they need replacing. They can also be tested, but you need a multi meter. If you've had the car a year or two and never replaced them, then it'd be worthwhile doing.

If you've had error lights then they would have saved an error code that could point you in the right direction. But will need scan tool to check codes.

Sometime exhaust and cats can cause problems with O2 sensors so if any of this work is recent then it could be causing your problems, then you'd need re tune due to exhaust and cats (if you did cats).
 

vz6lt

New Member
Joined
Jul 4, 2013
Messages
6
Reaction score
0
Points
0
Age
39
Location
brisbane
Members Ride
vz calais 6lt
i did cats and all that before my tune but did my gear box after my tune i had the gearbox and ecu diagnosed no error codes showed up thats why im stumped im running out of things to try
 
Top