Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Window gets stuck when winding up!

cameroony

New Member
Joined
May 18, 2009
Messages
16
Reaction score
0
Points
0
Location
Brisbane
Members Ride
VX Executive Wagon
I have a problem with the drivers side window in my VX. It is a manual wind up type. You can wind the window down easily but when you wind it up, it gets stuck every 360 rotation of the handle. If you wind the handle backwards a little, you can get another 360 rotation before it gets stuck and repeat this until it gets to the top.
What needs to be replaced to fix the issue?
 

Burnout124

Member
Joined
Jan 31, 2011
Messages
258
Reaction score
0
Points
16
Location
Western Australia
Members Ride
VY Executive S2/ VY SS 6sp
your window reg needs replacing. Some times it is just a small plastic runner brakes can be fixed for verry littel in this case.
 

Kieran263

Member
Joined
Apr 18, 2010
Messages
370
Reaction score
20
Points
18
Location
Natimuk
Members Ride
VE Calais Wagon 6.0 A6
haha exactly the same problem I had. I just got really angry at it one night
and punched the door real hard, haven't had a problem since :D
 

Hangman

Aspiring Sociopath
Joined
Jan 13, 2010
Messages
1,276
Reaction score
13
Points
38
Location
Newcastle, home of Toranafest
Members Ride
WK Land Yacht
I had a similar issue in my VP. The rubber that the front edge of the glass sits in had split inside the door and the glass was getting caught in it as it went up. I just cut the split bit off (it's just a work hack) and it's never done it again. Got an occasional rattle when the windows down now though...
 

admk69

New Member
Joined
Feb 19, 2011
Messages
20
Reaction score
1
Points
3
Location
Adelaide
Members Ride
VX Acclaim S2 2002 Wagon
I have same problem

Vx
took the door apart had a look at the mechanism. i could not find a way to fix it. the problem is in the winder area. I think the teeth in the cog have something to do with it?
I wd40'd it and put in back together. The WD40 did help some...

Did ya get yours fixed?
 
Top