Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Engine idling rough VY S2 Commodore

Discussion in 'VY Holden Commodore (2002 - 2004)' started by Black-ice, Oct 18, 2012.

  1. Black-ice

    Black-ice New Member

    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Oct 18, 2012
    Location:
    Adelaide
    Members Ride:
    VY Executive S2
    Hi all. First post on here. Thanks for reading. I have recently purchased my new commodore and have noticed that when its idling or stoped at lights, the engine is running a little rough like its missing. Its done a touch over 200k. I have recently serviced it changing oil, spark plugs and filters. Does anyone know where I could start to look for this problem. When its driving, it runs sweet. Thanks
     
  2. mr calais 5.0

    mr calais 5.0 New Member

    Messages:
    1,723
    Likes Received:
    1
    Trophy Points:
    0
    Joined:
    Jun 7, 2011
    Location:
    victoria
    Members Ride:
    vy s 2003
    Hello and welcome aboard.. Have you cleaned the throttle body? That could help or might be the tpc
     
  3. SID888

    SID888 New Member

    Messages:
    444
    Likes Received:
    3
    Trophy Points:
    0
    Joined:
    May 22, 2012
    Location:
    Northern Beaches, Sydney
    Members Ride:
    VX1 5.7L Berlina Wagon A4
    Have you changed the leads?
     
  4. Black-ice

    Black-ice New Member

    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Oct 18, 2012
    Location:
    Adelaide
    Members Ride:
    VY Executive S2
    No to both above. Ill try the cleaning throttle body before changing leads. What are the chances of the injectors needing cleaning?
     
  5. mr calais 5.0

    mr calais 5.0 New Member

    Messages:
    1,723
    Likes Received:
    1
    Trophy Points:
    0
    Joined:
    Jun 7, 2011
    Location:
    victoria
    Members Ride:
    vy s 2003
    Do you run the car low? Could try injector cleaner next time you fill up..
     
    Last edited: Oct 19, 2012
  6. Dr HaxZaw

    Dr HaxZaw New Member

    Messages:
    1,462
    Likes Received:
    9
    Trophy Points:
    0
    Joined:
    May 6, 2010
    Location:
    Sydney
    Members Ride:
    R34 GT-T
    mine seems to idle rough as well but i gave up chasing the problem because nothing fixed it lol now im just used to it
     
  7. VY_SP4C

    VY_SP4C Member

    Messages:
    156
    Likes Received:
    1
    Trophy Points:
    18
    Joined:
    Apr 1, 2013
    Location:
    Perth
    Members Ride:
    Vy SPac
    sorry to pull up an old thread but did you ever find the problem?
     
  8. 2greedy

    2greedy VP Calais (SSV)

    Messages:
    162
    Likes Received:
    1
    Trophy Points:
    18
    Joined:
    Apr 4, 2006
    Location:
    Queensland
    Members Ride:
    VY SS HBD6speed manual 5.7ltrs of manual GRUNT!!!
    yea i'd like to know too cause mines doing the same
     
  9. Shannan

    Shannan New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Aug 3, 2017
    Location:
    Miles qld
    Members Ride:
    Vn commodore
    I have a vy commodore 2002 it has done alot of ks.
    On idel it feels like it going to stall but it does not.
    It idels around 700.
    I have changed leads,plugs,dfi,coils
    I have run out of ideas.
    The only other thing i could think of is the air flow sensors that sit on the side of the throttel body.
    Any ideas would be greatly appreciated.
     
  10. evBenji

    evBenji Active Member

    Messages:
    990
    Likes Received:
    52
    Trophy Points:
    28
    Joined:
    Dec 22, 2010
    Location:
    Adelaide
    Members Ride:
    VY Commodore
    Yes or could be a hole in a vacuum hose.

    See the hoses coming off the throttle body id replace all of them just take one off at a time take into shop say u wanna new one

    Then get tb cleaner and clean out your tb and spray all the gunk off the idle air controller, 2 screws on the back pops out, or get a new one

    Else check your battery leads are neat and clean and tight

    Tighten up all screws on air intake so no air leaks. Ecotec loves air so if u get it all sealed up she purrs
     
  11. Trevor loves holden.

    Trevor loves holden. Well-Known Member

    Messages:
    1,139
    Likes Received:
    219
    Trophy Points:
    63
    Joined:
    Jun 6, 2019
    Location:
    Victoria
    Members Ride:
    vs commodore
    The MAF should be ok if you want to clean it use proper cleaner for MAF, 99% of the time its the IAC valve carboned up, also check for leaks past the MAF sensor. Don't waste money on injector cleaner just put a full tank of 98 octane it has more cleaning agent than 91.
     
  12. TheIceman

    TheIceman Member

    Messages:
    319
    Likes Received:
    0
    Trophy Points:
    16
    Joined:
    Mar 18, 2006
    Members Ride:
    VY Ex-cop
    pull throttle body off completely, pull apart and clean up and put back in and set base idle, should be good.
     

Share This Page