Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

engine light

DST300

New Member
Joined
Oct 11, 2006
Messages
2
Reaction score
0
Points
0
Members Ride
VT SS 5.7L
Just wanted to know what the problem can be if the engine light stays illuminated while driving. Once started after a few seconds it comes on is this a comon problem just wondering what it can be before taking it in
 

Demons1964

Member
Joined
Feb 2, 2004
Messages
453
Reaction score
15
Points
18
Age
44
Location
SE Melbourne
Members Ride
VY Calais, WHII Statesman V8, VC L 202
If you've got a series 2 VT, and you haven't noticed any change in idle or shifting it will most likely be a faulty oil pressure switch. And unfortunately only Tech2 gear can read and clear the fault. Very common failure on the LS1.

If you've got a series 1 VT forget what I said, you can grab the fault codes yourself.
 

Trewman

New Member
Joined
Oct 5, 2004
Messages
437
Reaction score
3
Points
0
Age
33
Location
Melbourne
Members Ride
VF SSV
Get the fault codes from the computer, it could mean a number of things.
 
I

Inferno

Guest
can also be the O2 sensors....i recently got an exhaust system installed and the engine light came on every now and then but the driving wasnt affected. whacked some new sensors in and bobs ur uncle :)
 

minux

Infidel Bear
Joined
Feb 6, 2005
Messages
6,927
Reaction score
232
Points
63
Location
Melbourne
Members Ride
300rwkw FG G6ET/Specialized Tarmac SL4
can also be gearbox canalso be about 50 other things.
 

mrbobcool

mrbobcool
Joined
Oct 8, 2005
Messages
11
Reaction score
0
Points
0
Age
75
Members Ride
VT SS
Had engine light coming on in my Gen 3 and took it to HP Tuners at Wagga.

Fixed it in two minutes by replacing a small hose that jions the PVc at the top front right side of the engine which had rotted right through.

After time the hose deteriorates and softens with the presence of oil and the engine sensors indicate the motor is running to lean and triggers the sensor light to come on.
 

Shounak

The Kicking Horse
Joined
Apr 20, 2005
Messages
2,500
Reaction score
60
Points
0
Age
34
Location
Vic
Members Ride
VX Executive S2 + XF Panel Van Project
Had engine light coming on in my Gen 3 and took it to HP Tuners at Wagga.

Fixed it in two minutes by replacing a small hose that jions the PVc at the top front right side of the engine which had rotted right through.

After time the hose deteriorates and softens with the presence of oil and the engine sensors indicate the motor is running to lean and triggers the sensor light to come on.
What legends.. They could have used it as an opportunity to rape you and suck you dry..
 

billsss

New Member
Joined
Nov 29, 2008
Messages
1
Reaction score
0
Points
0
Members Ride
Vu ss Ute 5.7
Hi guys, I'm new to this forum stuff, but was reading through forums to try and find out why my engine light was comming. I had changed the O2 sensers, the engine light kept comming on every now and then. after reading through this forum, I checked my PVc and found that it was split due to deterioation. Just like to say thank you for being so clude up . Thanks guys
 
Last edited:
Top