Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Indicators permantely on

Discussion in 'VT - VX Holden Commodore (1997 - 2002)' started by Bennyrach99, Dec 1, 2018.

  1. Bennyrach99

    Bennyrach99 New Member

    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    Joined:
    Sep 10, 2018
    Ok guys and gals ive researched this till im blue in the face and getting no where.hahah

    So i have a 1999 vt series 1 with the 3.8. Now currently fuse for hazard switch is pulled as all indicators will stay on permanently not blinking but solid no matter if cars on or off.
    Now indictors didnt work so replaced hazard switch so indicators worked but still couldnt put fuse in for hazards as they still stayed on permately. After about three weeks when i indicate all indicators flash not just right or left, all of them. I have noe replaced flasher unit, brand new genuine hazard switch and tried bcms we had sitting at work which are known good ones for testing. I have checked all bulbs and no corrosion. I have even di-electric greased all fitting and fitted new bulbs. Ive pulled the indicator stalk and cleaned it. Buuuuuttt still all 4 indictors flash no matter direction i indicate and if i put fuse in for hazards all indicators or on solid permately.

    Any help guys would be amazing im not big with electrics. Thinking fire may be best option at this point.hahaha

    Apologies for the short story.haha
     
  2. lout

    lout Well-Known Member

    Messages:
    2,151
    Likes Received:
    197
    Trophy Points:
    63
    Joined:
    May 13, 2006
    Location:
    Langwarrin Victoria
    Members Ride:
    VX Executive S2
    do you have trailer wiring
    is every light working as it should ie parkers brake lights etc
    have you been playing the LED game
    by the way i like your detailed description of the fault, most people write indicators stuck on and we have to play 20 questions to determine the exact fault
    it's too hot right now to dig out a wiring diagram, so check the above first
     
  3. Bennyrach99

    Bennyrach99 New Member

    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    Joined:
    Sep 10, 2018
    Previous owner fitted led low beams but otherwise everything is stock and everything is working as it should i even pulled all other lights and cleaned them just in case.
    I have no trailer wiring either no towbar at all.

    Cheers man no point me beating round the bush and i never like asking for help so tried everything i could think of first im now clutching at straws.hahaha

    I know the heat today is insane my garage is an oven!!! Haha
     
  4. lout

    lout Well-Known Member

    Messages:
    2,151
    Likes Received:
    197
    Trophy Points:
    63
    Joined:
    May 13, 2006
    Location:
    Langwarrin Victoria
    Members Ride:
    VX Executive S2
    ok . had a quick look
    it looks like the problem is in the bcm
    i know you have swapped it out
    it is possibly a short in the wiring, but i doubt it
    refit fuse 7 and unplug the hazard switch, are the indicators fixed on
    using your remote to lock and unlock do the indicators flash?
     
  5. gohrdrgomad

    gohrdrgomad Active Member

    Messages:
    249
    Likes Received:
    45
    Trophy Points:
    28
    Joined:
    Dec 16, 2016
    Location:
    Australia
    Members Ride:
    VxCaly57
    l have no idea so just a possibility the emobilizers have hazard function maybe check something out with that.
     
  6. lout

    lout Well-Known Member

    Messages:
    2,151
    Likes Received:
    197
    Trophy Points:
    63
    Joined:
    May 13, 2006
    Location:
    Langwarrin Victoria
    Members Ride:
    VX Executive S2
    the immobilizer has a double pole relay inside the bcm which is what i suspect is welded closed
    but baby steps in the diagnostics
    no turning to the back page to see how the story ends
     
  7. gohrdrgomad

    gohrdrgomad Active Member

    Messages:
    249
    Likes Received:
    45
    Trophy Points:
    28
    Joined:
    Dec 16, 2016
    Location:
    Australia
    Members Ride:
    VxCaly57
    l was just putting my 10 cents worth in..
     
  8. Bennyrach99

    Bennyrach99 New Member

    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    Joined:
    Sep 10, 2018
    Cheers guys ill have a look after dinner and let you guys know.

    Thanks for the help
     
  9. Bennyrach99

    Bennyrach99 New Member

    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    Joined:
    Sep 10, 2018
    Alright so i unplugged the hazard switch and put the hazard fuse back in. Indicators were all on not blinking but solid and not turning off. I got out closed the door and locked the car with the remote and nothing indicators stayed on. So i unlocked the car and there was a slight flicker in the indicators. So i locked the car again after a second or two indicators went out. I unlocked the car and lights flashed as normal.
    Got back in the car hooked up the hazard switch and tested hazards and indicators. Everything is now working as normal.

    How and why it all works now i dunno but im not going to complain.hahah

    Thanks for the replies and help guys!!
     
    Brady Leighton likes this.
  10. lout

    lout Well-Known Member

    Messages:
    2,151
    Likes Received:
    197
    Trophy Points:
    63
    Joined:
    May 13, 2006
    Location:
    Langwarrin Victoria
    Members Ride:
    VX Executive S2
    sorry to say but that almost confirms fault is in bcm
    next time indicators latch on not blinking
    without changing any conditions
    unplug the connectors from the bcm
    if the lights go out that will be 100% confirmation
    keep your fingers crossed, it may go years without faulting again or may happen tomorrow
    watch the battery voltage, low voltage will worsen this
     
  11. oska

    oska Active Member

    Messages:
    783
    Likes Received:
    34
    Trophy Points:
    28
    Joined:
    Oct 14, 2010
    Location:
    melbourne
    Members Ride:
    vx custom 600RR
    there's no relay in the BCM for the indicators or hazards, the extra relay was only introduced in VY

    check both relays otherwise there is a wiring fault that the previous owner has done
     
  12. gohrdrgomad

    gohrdrgomad Active Member

    Messages:
    249
    Likes Received:
    45
    Trophy Points:
    28
    Joined:
    Dec 16, 2016
    Location:
    Australia
    Members Ride:
    VxCaly57
    Did l ern my 10 cents..
     
  13. lout

    lout Well-Known Member

    Messages:
    2,151
    Likes Received:
    197
    Trophy Points:
    63
    Joined:
    May 13, 2006
    Location:
    Langwarrin Victoria
    Members Ride:
    VX Executive S2
    sorry we have to split it two ways
    so 5 cents each
     

Share This Page