Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

LCD display problem

OldAndyMac

New Member
Joined
Dec 5, 2011
Messages
38
Reaction score
1
Points
0
Location
Brisbane
Members Ride
VZ SV8
Hi guys

Weird thing happened today. The LCD display on the dash is all messed up - every 'pixel' is on and it stays like this even when the engine is off. I have tried to disconnect the battery for 5 mins but it just comes back?!?

There are no other problems and and can still change the function of the dash computer as i can hear it beeping - I just cant see anything as it is all 'blacked out'.

Any ideas?
 

franklinfrog

Member
Joined
Oct 6, 2009
Messages
581
Reaction score
5
Points
18
Location
Brisbane
Website
www.cheapbrisbanebikes.com
Members Ride
VY SS Wagon 5.7 Auto Wikid Postie Bike
Someone in the vy section had this issue a few days ago, check that thread. Pretty sure the best solution is to replace whole cluster but they're going to attempt to solder new lcd screen into existing cluster. I've heard that just the screen can be changed by instrument shops or expert soldering geeks.
 

OldAndyMac

New Member
Joined
Dec 5, 2011
Messages
38
Reaction score
1
Points
0
Location
Brisbane
Members Ride
VZ SV8
thanks for the info. Im not sure if a new cluster will fix it as the LCD is not actually broken, it is still able to display. Hard to explain, have a look at what i mean here:

When i start the car it will show the mileage for a split second but then revert back to the display shown in the link. It stays on like this all the time unless I pull a fuse.
 

franklinfrog

Member
Joined
Oct 6, 2009
Messages
581
Reaction score
5
Points
18
Location
Brisbane
Website
www.cheapbrisbanebikes.com
Members Ride
VY SS Wagon 5.7 Auto Wikid Postie Bike
Yeah agreed, just looks like it's stuck in test mode, but the actual lcd is ok. In my vy, if I hold mode and set then turn ignition to on and press mode a few times there is a test screen like this. Might be worth cycling through this to try to get it out of this mode. No idea if this will work. Never seen this before, anyone else ideas?
 

Realway

New Member
Joined
Aug 2, 2012
Messages
5
Reaction score
0
Points
0
Location
Port Stephens
Members Ride
VZ ute
I have the same problem on my VZ ute as of yesterday. I stopped and filled the tank and then started the car and this screen, exactly as this photo appeared. Has anyone found a fix for this?
 

TazzI

Envyous Customs
Joined
May 24, 2011
Messages
1,078
Reaction score
370
Points
83
Location
Western Australia
Website
www.envyouscustoms.com
Members Ride
Holden VE SS Ute
The problem is that something on the board gets fried, this could be due to dry solder joint, water getting into the system, or too much voltage running through the car for too long. Its not really something that can be fixed since there are so many components on the cluster board.

Changing the lcd doesnt help, as it isnt the lcd that is damaged, it is generally the cluster board that has the problem.
Seems the contrast pin/s on the lcd become set to "full".. meaning that the entire lcd screen is on.

Only solution is to replace the cluster. And before doing so, Id suggest double checking the voltage going into the cluster to ensure theres not something wrong there.
 

Realway

New Member
Joined
Aug 2, 2012
Messages
5
Reaction score
0
Points
0
Location
Port Stephens
Members Ride
VZ ute
By replacing the "cluster" do you mean the whole instrument panel or just the actual display part. Any idea on costs? Thanks for your quick reply by the way.
 

TazzI

Envyous Customs
Joined
May 24, 2011
Messages
1,078
Reaction score
370
Points
83
Location
Western Australia
Website
www.envyouscustoms.com
Members Ride
Holden VE SS Ute
When I say cluster, I mean the entire instrument panel, replacing the LCD doesn't work as it generally isn't an lcd issue as said above, it is a dodgy component.

A stock standard lvl1 instrument cluster should go for around $60. Wouldn't bother with eBay, is full of overpriced clusters with zero programming.

I'd suggest looking on gumtree for a cluster from a wrecked car with the same airbag setup, transmission, engine size and body type to avoid any unwanted warnings or incorrect dial displays.
 

Get Electronic

New Member
Joined
Oct 31, 2016
Messages
1
Reaction score
0
Points
0
Age
32
Location
New Zealand
Members Ride
VY
Repaired VY - VZ Dash Cluster LCD

When I say cluster, I mean the entire instrument panel, replacing the LCD doesn't work as it generally isn't an lcd issue as said above, it is a dodgy component.

A stock standard lvl1 instrument cluster should go for around $60. Wouldn't bother with eBay, is full of overpriced clusters with zero programming.

I'd suggest looking on gumtree for a cluster from a wrecked car with the same airbag setup, transmission, engine size and body type to avoid any unwanted warnings or incorrect dial displays.
Get Electronic in New Zealand repair this fualt

Holden VY Dash dash LCD gone
 
Top