Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Radiator hose clamps

VYMAD

SILVERFOX
Joined
Jun 6, 2008
Messages
1,908
Reaction score
13
Points
38
Age
46
Location
BUNDABERG Q
Members Ride
VY EXECUTIVE S2
What are your thoughts of the original
factory raddy hose clamps, you know the
ones that press together with multi's to
release?
My upper and lower hoses each have one
of these on each end and the bottom one,
raddy end has lost a bit of its 'spring'
over the years, as this has been removed
several times to conduct coolant changes.
Maybe this is where my mystery coolant
leak is coming from.
Anyway I'm going in
to get Tridon hose clamps today, just
wondering if ya's have had probs with
the factory ones?
 

Demonica

Donating Member
Joined
Mar 15, 2010
Messages
717
Reaction score
7
Points
18
Location
SE Qld
Members Ride
VS clubsport
Plenty of issues and they're such a pain in the ass to get off >.< I had a slightly loose clamp the other day that led to a slight leak so hopefully a new clamp fixes your issue :)
 

edals

Well-Known Member
Joined
Sep 30, 2008
Messages
1,907
Reaction score
59
Points
48
Location
-
Members Ride
-
Quite useless clamps, Really a 1 time use thing. Ditch them and get new ones, they use these in factory cause its faster to fit
 

Cheap6

New Member
Joined
Jun 19, 2005
Messages
2,498
Reaction score
74
Points
0
Members Ride
VP Exec
They're good on "as new" hoses in that they automatically provide the correct tension force and prevent over clamping. They're not so good when the hoses age, unless you use them as an indication that it's time to replace the hoses.

My preference in clamps is to use the worm drive type that have a stainless steel band and through holes i.e. not the type that have the 'gear' pressed into the band.
 

Dayvo

Because i can
Joined
Apr 28, 2005
Messages
2,586
Reaction score
4,344
Points
113
Age
65
Location
South East,Victoria
Members Ride
VE SV6 Series 2
I nearly cooked my motor a couple of months back because my bottom hose came off from the radiator . The clamp was still on the hose but had lost some of its tension . Bin them and get the worm drive ones.
 

VS_Pete

Donating Member
Joined
Dec 23, 2007
Messages
4,937
Reaction score
22,390
Points
113
Location
Brisbane
Members Ride
VE II SV6 MY12 SPORTWAGON
New hoses New clamps that is all.
 
Top