Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VT Calais "Trac Off" Light coming on

stirringaxe

Member
Joined
Jun 30, 2006
Messages
143
Reaction score
1
Points
18
Location
Elsewhere
Members Ride
07
PROBLEM SOLVED SEE BELOW!


Hi guys, I'm a newbe here.

I have the Trac Off light coming on sometimes & it will not go out unless I turn ign off & restart the engine.

This is an ittermittant fault happening every few days or so.

I have searched the threads & it sounds similar to the ABS Module faults listed by others.

Is this the case ??

If so where on the vehicle is the module mounted ?

(see 2 pics attached)

Are either of these it ?
 

Attachments

Last edited:

Optimus_Prime

New Member
Joined
Aug 14, 2005
Messages
37
Reaction score
0
Points
0
Age
40
Location
WA
Members Ride
'06 Clubsport R8
Do you have traction control?

Its supposed to only turn off when you manually switch it yourself, and will reset to default ON when you turn the ignition off & on again.
 

stirringaxe

Member
Joined
Jun 30, 2006
Messages
143
Reaction score
1
Points
18
Location
Elsewhere
Members Ride
07
Yep have definately got traction control.

When this problem happens the button has no effect on turning the trac off or on....
 

WinterVX

Member
Joined
May 15, 2006
Messages
325
Reaction score
3
Points
18
Location
Melbourne
Members Ride
N/A
I had the same sort of issue a few months back, appart from the fact I just wasnt
able to turn trac control off or on manually. Might be worth asking Holden or a mecahnic
to check out the lines to your ABS module, they may have become worn or rusting out,
and shorting the switch out.

This is what happened with mine, Tech refreshed the connections and cleaned out
all the crap over the years, and works perfect again.

Worth a shot :thumbsup:
 

stirringaxe

Member
Joined
Jun 30, 2006
Messages
143
Reaction score
1
Points
18
Location
Elsewhere
Members Ride
07
Thanks for the help & advice guys.

I still want to know where the ABS Module is mounted ?

(see 2 pics attached above)

Are either of these it ?
 

accentstencil

Well-Known Member
Joined
Jun 30, 2005
Messages
8,267
Reaction score
462
Points
83
Age
69
Location
Eschol Park, Sydney
Members Ride
WH II Caprice, 5.7 2018 Equinox LTZ V
Thanks for the help & advice guys.

I still want to know where the ABS Module is mounted ?

(see 2 pics attached above)

Are either of these it ?
Picture 1 is your ABS module.

the easiest way to find out if it has a faulty ABS module is
start the car & when the lights come on, is the oil light on?
if so unplug the big connector on the ABS & see if the oil light goes off.
if it does it will need a new ABS module, now there have been a few people say to remove the connector & clean it will fix it, i have never seen this as a long term repair, the fault is a known electronic issue in the module & no amont of cleaning the connector will fix it permanently

Rob
 

WAGON MAN

Gas Sleeper
Joined
Jun 7, 2006
Messages
1,059
Reaction score
12
Points
38
Location
North Coast , NSW
Members Ride
VX S2 Berlina Wagon with Phreddied bits.
stirringaxe have a look at this thread:thumbsup:
 

stirringaxe

Member
Joined
Jun 30, 2006
Messages
143
Reaction score
1
Points
18
Location
Elsewhere
Members Ride
07
Update....

I had this issue & checked out the ABS module & all sorts but, no faults were found. The local Holden mechanic said this to me after all the wasted effort:...

" When you start this model wait for at least 3-5 seconds after the engine is running before you engage drive or reverse because the ABS module takes a little bit of time to do its checks & be ready for work "

"If you move off too quickly the trac light will come on & can't be turned off till you restart the engine again"

Now I don't know if that is true or not, but since being told this & following his advice, my trac light has never come on again while driving........
 

VTcalaiskerst

Larry Perkins is my hero!
Joined
Feb 22, 2007
Messages
3
Reaction score
0
Points
0
Location
the middle of nowhere
Members Ride
VT Calais S1
same prob

I have the same problem with my VT calais. I have the abs and trac off lights come on but have noticed (sometimes) if I turn the car off then on again it wont come back on. I also noticed that if my petrol tank is full the lights dont come on till I have used at least half a tank?
I tried the 3-5 sec wait but they still stayed on.
I will have a look at the contacts and give them a clean to see if it helps.
Otherwise I am off to the mechanics.
 
Top