Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

vt right hand indicator clicking fast and flashing fast

YILDI2

New Member
Joined
Mar 20, 2009
Messages
150
Reaction score
2
Points
0
Website
www.myspace.com
Members Ride
FG XR6 TURBO /RIP VT II LS1 Clubby, VR Commodore S
hi guys i just purchased a vt series 2 clubby last nite, so im new to the vt section
the right indicator flashes faster then left
on the rear front and side of the right of the car flashes fast,
do i just need new globes, or fuse ?
if anyone could help me out, i searched but all i got was clicky indicator stalks
thanks
 

Jarrad

Sherminator
Joined
Oct 10, 2006
Messages
78
Reaction score
0
Points
6
Location
Wollongong
Members Ride
Silver Ex Cop VX Wagon
Yep blown globe, check them and replace the blown one and all should be sweet!
 

Tree cutter

Tree cutter
Joined
Apr 15, 2006
Messages
1,020
Reaction score
8
Points
38
Location
Mt Gambier SA
Members Ride
VX Calais SuperchargedV6
If all the indicator globes are working then look to see if one is duller than the one on the other side at the same position. If someone has put a globe in that has a lower wattage than the original then that side will flash faster.
 

graham7773

Active Member
Joined
Oct 6, 2008
Messages
1,053
Reaction score
15
Points
38
Members Ride
VT Acclaim Wagon
While you are checking the globes, look in the fitting for corrosion. Bad earthing can cause this problem.
 

Rhin0o8

New Member
Joined
May 30, 2010
Messages
237
Reaction score
7
Points
0
Members Ride
VZ Calais Impounded?
While you are checking the globes, look in the fitting for corrosion. Bad earthing can cause this problem.
+1 . check the bayonet for cracking or splitting
The globe wont sit right and will earth out

VT's are bad for this especially in the Brake/Tail light wiring looms
 
Last edited:

vteezr

Defected
Joined
Jul 28, 2010
Messages
17
Reaction score
0
Points
0
Age
30
Location
Renmark
Members Ride
VT Acclaim 3.8 S2
I had to replace almost all of my rear light fittings i kept blowing globes all the time. Took me awhile to realise why :/
 

a1k3m1

New Member
Joined
Feb 3, 2010
Messages
359
Reaction score
1
Points
0
Location
Central Victoria
Members Ride
2003 VY II S-Pack 25th Anniversary
as everyone else has said .. youve got a shonky globe or bad wattage globes, or theres no connection to the globes lol .. could also be a shonky flasher relay aswell. But my first guess would be the globes
 

YILDI2

New Member
Joined
Mar 20, 2009
Messages
150
Reaction score
2
Points
0
Website
www.myspace.com
Members Ride
FG XR6 TURBO /RIP VT II LS1 Clubby, VR Commodore S
thanks guys, sorry for the reply, just been flat out with my new job
the indicators were normal again at one stage and now flashing faster on left side
i will have a look for cracks and watts of the globes, thanks alot guys :)
 
Top