Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

fixing the odo/trip

VL Berlina 5speed

Apprentice Panel Pusher
Joined
Oct 3, 2005
Messages
2,684
Reaction score
30
Points
0
Age
33
Location
Adelaide
Members Ride
Project VL Show car, VS Exec, VY Ute, YZ250F
Countess said:
has the speedo stopped as well or just the odo?

if its just the odo then you need to pull dash out & put a bit of glue on the white cog so it stops slipping & actually makes contact again. All fixed!


D.
found this old post, any1 tryed it? dose it work
 

harry3

New Member
Joined
Jul 23, 2005
Messages
928
Reaction score
8
Points
0
Age
71
Location
melbourne
Members Ride
vl berlina wagon 6cyl
failure of the odomoter is common, an instrument repairer would know the cure, also ask a holden dealer
 

VL Berlina 5speed

Apprentice Panel Pusher
Joined
Oct 3, 2005
Messages
2,684
Reaction score
30
Points
0
Age
33
Location
Adelaide
Members Ride
Project VL Show car, VS Exec, VY Ute, YZ250F
yah i know you can buy the cogs for like $11, but the idea of glue wouldnt it just stick together and jam
 

Bax

Projecting
Joined
Jan 9, 2004
Messages
3,502
Reaction score
36
Points
0
Age
37
Location
QLD
Members Ride
Nothing
Yeah I thought glue would have jammed it. Maybe a new cog if you want to fiddle with something so small.

It'd be easier to either get a new piece from the wreckers, or get it repaired properly I'd say.

Theres a guy here that does VDO repairs, he will take your dash, fix your bulbs, everything for about 70 dollars I think. Depending on whats wrong with it of course.
 

NORTI

Crazy VS lady
Joined
May 22, 2004
Messages
2,587
Reaction score
441
Points
83
Location
Adelaide
Members Ride
Wildtrack
if you would like the link to photos & step by step, then PM me.



D.
 
Top