Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VT Calais Engine Turning Off

harrydinho

New Member
Joined
Sep 3, 2012
Messages
3
Reaction score
0
Points
0
Age
29
Location
NSW
Members Ride
VT Calais Series 2
Hi,

I am having a problem with my VT Calais's engine randomly turning off and not starting again for a while. All the electronics stay on when this happens and when I try to start it again I can hear the starter motor trying to start but that's all. Also, the car seems to rev roughly every now and then when idling (not sure if this is the same issue).

I have replaced the crank, full pump and crank angle sensor.

I have also had someone unscrew an adapter and align the pins on this adapter. It's towards the front right of the engine (can provided photos) and that seemed to fix it for about a week. He seemed to think that this adapter loosened and the pins weren't touching causing the engine to turn off.

Hoping someone else has had experience with something like this. Any help would be greatly appreciated :)
 

Brett_jjj

Well-Known Member
Joined
Oct 16, 2009
Messages
6,805
Reaction score
82
Points
48
Location
Tamworth NSW
Members Ride
vs commodore
Thats probably the DFI module that youre talking about, its under the 3 ignition coils and it has either a small bolt or screw that holds the wiring connector in place.. You may have to find another DFI module if the connector pins are bent etc, either second hand, or better still, a new one. Look on ebay under "DFI commodore"
 

harrydinho

New Member
Joined
Sep 3, 2012
Messages
3
Reaction score
0
Points
0
Age
29
Location
NSW
Members Ride
VT Calais Series 2
That's it, thank you. I think I might change the connector too because the pins didn't look too great and just as a precaution. Would that be called the DFI terminal or something like that?

Thank you for you help
 
Top