Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VY ss Trac off

fragger

New Member
Joined
May 5, 2019
Messages
5
Reaction score
0
Points
1
Age
49
Location
Campbelltown
Members Ride
vy ss
Since installing LED J.W.Speaker BAY15d rear brake lights the Trac off will not turn off when the car is started. Tried many times pressing the T/C button and nothing, any help
 

accentstencil

Well-Known Member
Joined
Jun 30, 2005
Messages
8,266
Reaction score
461
Points
83
Age
69
Location
Eschol Park, Sydney
Members Ride
WH II Caprice, 5.7 2018 Equinox LTZ V
I would try putting the old globes back in to see if that fixes the problem. The LED's might need a load resistor.
 

krusing

Well-Known Member
Joined
Jun 21, 2014
Messages
2,958
Reaction score
1,463
Points
113
Location
Melbourne Bayside 3193
Members Ride
2002 VY L67 Calais Sedan, 2012 VE L77 Calais Wagon
I put LED Brake/Tail Light Globes in my VXII when I had it, and the Cruise Control didn't work,
Put the old globes back in, it started to work ok.
Don't waste your money on LED Globes,
the LED's seem to fail, and that will render the vehicle un-roadworthy,
yes, even if 1 LED fails, they will deem it un-roadworthy.
Taking in to account, unless the vehicle is setup LED Globes/Lights, they will never work properly.
 

fragger

New Member
Joined
May 5, 2019
Messages
5
Reaction score
0
Points
1
Age
49
Location
Campbelltown
Members Ride
vy ss
Thanx guys, I have worked it out, the LED brake lights need a load resistor fitted, as both the cruise control and trac control don’t work. When I put in normal globes, everything work fine, thanx for your help again
 
Top