Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Check engine warning.

8SiX3_

New Member
Joined
Aug 17, 2012
Messages
2
Reaction score
0
Points
1
Location
Perth
Members Ride
VY Clubsport S2 R8
Hey,
I've been getting an check engine error coming off and on for last 2 months in my Holden 08 VE SS. I took it to super cheap to get it diagnosed, and it come back with two errors.
1st : P0222 : Throttle valve position sensor 2 : signal to small.
2nd : P2135 : Accelerater pedal position sensor 1/2 : malfunction.
Can any tell me more in depth what these two errors mean. And would I be looking at replacing both effected parts, or good it be just the sensors that are faulty?
Can you replace the sensor on a VE SS throttle body, or does the whole throttle body need to be replaced. By looking around they range in price from $280 2nd hand or $1100 new. I've been told it's unlikely the throttle body is damaged or faulty the cars only done 93k kms.
The way I'm kinda seeing it, is the two sensors are no good or are not lining up.?
I have spoken with a mechanic who has said I could try cleaning out the throttle body, but it's unlikely to fix the issue in the long run, and best option would be to replace.
Any info or advice would be much appreciated. Thank you.

Jason.
 

Attachments

krusing

Well-Known Member
Joined
Jun 21, 2014
Messages
2,937
Reaction score
1,435
Points
113
Location
Melbourne Bayside 3193
Members Ride
2002 VY L67 Calais Sedan, 2012 VE L77 Calais Wagon
Does it still drive ok ?
That was my first thought for the Throttle Body, Clean it out,
& Reset the Position of the Accelerator Pedal.
If that doesn't work, Replace the Parts.
The other option would be if you want to replace the parts, go the Wreckers and see if you can find them there.
At least its a starting point.
 

8SiX3_

New Member
Joined
Aug 17, 2012
Messages
2
Reaction score
0
Points
1
Location
Perth
Members Ride
VY Clubsport S2 R8
Yeah it drives OK, once or twice it lost power but Saturday I was at a drive though, in drive, foot on the brake and it reved a bit then felt like it was going to stall. Only time it's done it. The error comes and goes it's random...
Is there much involved in resetting the pedal?
 

krusing

Well-Known Member
Joined
Jun 21, 2014
Messages
2,937
Reaction score
1,435
Points
113
Location
Melbourne Bayside 3193
Members Ride
2002 VY L67 Calais Sedan, 2012 VE L77 Calais Wagon

krusing

Well-Known Member
Joined
Jun 21, 2014
Messages
2,937
Reaction score
1,435
Points
113
Location
Melbourne Bayside 3193
Members Ride
2002 VY L67 Calais Sedan, 2012 VE L77 Calais Wagon
Top