Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VF LS3 tick under car

Discussion in 'General' started by VFSSBlackLS3, Dec 20, 2018.

  1. VFSSBlackLS3

    VFSSBlackLS3 New Member

    Messages:
    13
    Likes Received:
    1
    Trophy Points:
    3
    Joined:
    Nov 18, 2018
    Location:
    Adelaide, Australia
    Members Ride:
    VF SS Black Edition, Series 2 LS3, 6 Speed manual
    Hi I realise that people have probably brought up issues like this in the past but now that the vehicles have been out for a couple of years I thought it might be better if I just made a new post...
    Basically when I get underneath my car I can hear a tick sound that sounds very similar to an injector sound but from underneath...and the funny thing is as I can't really tell if it's always been there or if I've just noticed it today and now that I've noticed it, I can't un-notice it!?
    So once again I'm not sure if the noise is always been there but I've just noticed it today and the cars done about 33000 km...
    Is a tick underneath the LS3 fairly normal? I don't think it had piston slap as I have had LS1s with slap and they took a while to warm up to put out power... this motor doesn't seem to act like that and this sound was 1st noticed when I got home from a decent drive
     
    stick3 likes this.
  2. VFSSBlackLS3

    VFSSBlackLS3 New Member

    Messages:
    13
    Likes Received:
    1
    Trophy Points:
    3
    Joined:
    Nov 18, 2018
    Location:
    Adelaide, Australia
    Members Ride:
    VF SS Black Edition, Series 2 LS3, 6 Speed manual
    Also I've owned a fair few LS1s and 304s... Is there anything an LS3 owner should know about the LS3 if going from LS1 to LS3 because I know the motors are very similar? What's the most common knowledge issue so far with the LS3???
     
  3. vr304

    vr304 Well-Known Member

    Messages:
    1,114
    Likes Received:
    210
    Trophy Points:
    63
    Joined:
    Feb 9, 2013
    Location:
    Auckland, New Zealand
    Members Ride:
    2007 ssv manual
    Exhaust tick mate if you have aftermarket headers, hi flow cats etc you will always get this to some degree, both my ve ss and vx LS1 did the same thing due to aftermarket headers and no cats ( I’m in nz) if your exhaust is all standard you possibly may have a leak somewhere
     
    VFSSBlackLS3 likes this.

Share This Page