Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VE SS - Replaced post o2 sensor - engine light is still on

elmazri

New Member
Joined
Jul 25, 2016
Messages
6
Reaction score
0
Points
1
Location
Melbourne
Members Ride
2008 Holden VE SS-V
I have a VE SS and engine light came on with a P2271 bank1 sensor 2, I replaced the O2 sensor on the driver side and cleared the engine code.

Engine code came back on 2 days later with the same code.

Could it be the catalytic converter?
 

lmoengnr

Well-Known Member
Joined
Jan 15, 2012
Messages
3,243
Reaction score
2,042
Points
113
Location
Sunbury Vic.
Members Ride
MY12.5 Maloo R8, MY12 Redline ute, Magnum 224
Try the same sensor on the passenger side.
 

vr304

Well-Known Member
Joined
Feb 9, 2013
Messages
1,579
Reaction score
417
Points
83
Location
Auckland, New Zealand
Members Ride
2007 ssv manual
Probably wouldn’t hurt to change them all if you can afford it they are a service item supposed to be replaced 5 yearly
 

Fu Manchu

Well-Known Member
Joined
Mar 18, 2006
Messages
4,355
Reaction score
2,076
Points
113
Location
WA.
Members Ride
Slug powered VZ, Cross 8 VZ, VE Calais & ya mum.
I've had plenty of issues similar when using non genuine O2 sensors.
 

syked

Donating Member
Joined
Feb 15, 2018
Messages
329
Reaction score
111
Points
43
Age
35
Location
Sydney
Members Ride
2011 WM Caprice
Can you read live data of the O2 sensors?

The pre-cat O2 sensors should be jumping between high and low voltage constantly and the post-cat O2 sensors should be steady high voltage. Check at idle and 2000rpm .
 
Top